VMware VCSA 7, 6.5, 6.7 Vcenter Appliance installation problem

Advertisements

VMWARE VCSA 7 , 6.5, 6.7 VCENTER APPLIANCE INSTALLATION PROBLEM (FAILED TO START SERVICES. FIRSTBOOT ERROR.)

The installation successfully completes stage 1, but not complete 2nd stage.
If we retry we will get the same error

Firstboot error
Failed to start Services. Firstboot error and vpxd service will not start

Or

Encountered an internal error. Traceback (most recent call last): File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 2017, in main vmidentityFB.boot() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 349, in boot self.configureSTS(self.__stsRetryCount, self.__stsRetryInterval) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1478, in configureSTS self.startSTSService() File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 1140, in startSTSService returnCode = self.startService(self.__sts_service_name, self.__stsRetryCount * self.__stsRetryInterval) File "/usr/lib/vmidentity/firstboot/vmidentity-firstboot.py", line 88, in startService return service_start(svc_name, wait_time) File "/usr/lib/vmware/site-packages/cis/utils.py", line 784, in service_start raise ServiceStartException(svc_name) ServiceStartException: { "resolution": null, "detail": [ { "args": [ "vmware-stsd" ], "id": "install.ciscommon.service.failstart", "localized": "An error occurred while starting service 'vmware-stsd'", "translatable": "An error occurred while starting service '%(0)s'" } ], "componentKey": null, "problemId": null }

Solution

We should have forward and reverse entries in domain controller.

This issue always comes if we are using static IP configuration or wrong domain entries.

Add this entry in vcsa’s hosts file and you are good to go. Once the configuration complete you can later add the vcsa in domain without any problems

VMware vCenter Service SSH login
Once stage 1 completes
Open a console to the appliance, enable SSH
On the appliance, echo ":: 1 localhost.localdom localhost" >> /etc/hosts

You can also wait till stage 2 is at 2%, and then add ” echo “::1 localhost.localdom localhost” >> /etc/hosts”.

Also, if you are facing the same issue update vcenter host entry in /etc/hosts file

Leave a Reply