Nutanix AHV

Multicast traffic stops working when balance-slb load balancing is used in AHV

MULTICAST TRAFFIC STOPS WORKING WHEN BALANCE-SLB LOAD BALANCING IS USED IN AHV

Issue:

Multicast traffic intermittently fails whilst using balance-slb on AHV. that is due to the mixture of IGMP pruning on the upstream switch and Open vSwitch only accepting traffic at the active slave.

Open vSwitch avoids packet duplication by way of accepting multicast and broadcast packets on only the active slave (one interface), and losing multicast and broadcast packets on all other slaves. With IGMP pruning multicast traffic is handiest sent from the upstream switch on the interface the IGMP join is received on.

Example

if two nics, eth0 and eth1, configured on AHV host with balance-slb LB nic team.

If eth0 is the active slave but the IGMP join is sent on eth1 the switch will not send multicast traffic on eth0.

Instead it is sent on eth1 resulting in OVS dropping the multicast traffic on the non-active slave.

Solution :

Please find the steps to resolve the issue


1. Move all hosts to the active-backup load balancing method.

2. Move all hosts to the LACP and balance-tcp load balancing with physical switch configuration.

3. Turn off “igmp snooping” for the vlan used for multicast traffic.

4. Turn off “igmp snooping” for the vlan used for multicast traffic.

5. Use static IGMP joins to send IGMP traffic on all ports going to the Nutanix hosts.

  • An example configuration for static IGMP join for vlan 66 for multicast group 249.0.0.1 on ports 1-4 on physical switch
ip igmp snooping vlan 66 static 249.0.0.1 interface ethernet 1-4

This would cause the specific multicast traffic to be sent to all switch ports configured

Recommend to create on br1 instead of br0 so we can not loose AHV and CVM connectivity.

All though in some cases its work awesome

Leave a Reply